Introduction
Privileged operators in OpenBao can abuse the audit subsystem to bypass intended security controls and execute code on the host. Any deployment that relies on operator privilege separation for secrets management is affected, and its sensitive environments are exposed to code execution and network access risks.
OpenBao is an open-source secrets management platform for managing, storing, and distributing sensitive data such as secrets, certificates, and keys. It is not as widely adopted as some commercial products, but it is gaining traction with organizations that want an open-source alternative for secrets management. The project has seen rapid development and adoption, and it has also had several critical vulnerabilities in recent releases.
Technical Information
OpenBao versions 2.3.1 and below have a code injection vulnerability in the audit subsystem. In these versions, privileged API operators can configure audit devices through the sys/audit/* endpoints. The audit device configuration includes a prefix parameter, which is meant to prepend custom strings to audit log entries for context or categorization.
OpenBao does not properly sanitize the input to the prefix parameter, so a privileged operator can inject arbitrary code or commands into the prefix. When an audit event is triggered, the system builds the log entry by concatenating the prefix with the audit data. If the prefix contains executable content, the underlying host or an external log processing system can interpret it as code. The operator can then execute unauthorized code or establish network connections, in violation of the intended security restrictions.
The root cause is insufficient input validation and sanitization of the prefix parameter in audit device configuration. Version 2.3.2 addresses the vulnerability and introduces new configuration options to disable audit mount creation via the API (unsafe_allow_api_audit_creation) and to disable audit log prefixing (allow_audit_log_prefixing).
Patch Information
OpenBao version 2.3.2 addresses this vulnerability by restricting access to the sys/audit/* interface and adding further security measures. Every deployment running version 2.3.1 or below should upgrade to 2.3.2 or later immediately.
- OpenBao 2.3.0 Release Notes
- OpenBao 2.2.0 Release Notes
- Snyk Advisory SNYK-CHAINGUARDLATEST-OPENBAO-9402424
- Snyk Advisory SNYK-CHAINGUARDLATEST-OPENBAO-9458919
- GitHub Advisory GHSA-xp75-r577-cvhp
Detection Methods
To detect this vulnerability and potential exploitation, monitor for these indicators:
- Unauthorized or unusual changes to the audit log prefix in the audit device configuration.
- Unexpected file system activity initiated by OpenBao, especially the creation or modification of binaries or scripts.
- Unexpected outbound TCP connections from the OpenBao server to external hosts.
Comprehensive logging and real-time alerting for these activities are recommended.
Reference: GitHub Advisory GHSA-xp75-r577-cvhp
Affected Systems and Versions
- OpenBao versions 2.3.1 and below are affected.
- Any deployment where privileged API operators have write access to
sys/audit/*endpoints is vulnerable. - The vulnerability is fixed in version 2.3.2.
Vendor Security History
OpenBao has fixed several critical vulnerabilities in recent releases, including:
- CVE-2025-52894: Unauthenticated users could cancel root rekey and recovery rekey operations (fixed in 2.3.1)
- CVE-2025-52893: Other privilege escalation issues
The vendor patches quickly and publishes detailed advisories. Still, the frequency of critical issues shows the project needs ongoing security review and improvement.



